Salesforce | Please use TLS 1.1 or higher when connecting to Salesforce using https

Author - Ashish

Salesforce login via PHP Salesforce Toolkit API may throw this exception:

Please use TLS 1.1 or higher when connecting to Salesforce using https

The reason is Salesforce has provided customers with the Critical Update feature Require TLS 1.1 or higher for HTTPS to maintain high Security. If you are connecting with TLS 1.0 this error can show up.

There are 2 solutions to this problem:

Solution 1:  Update version of Java to Java JRE 1.8 and use the latest SFDC toolkit to use TLS 1.1.

Solution 2: If solution 1 is not possible in your case then follow these steps to disable TLS 1.1 requirement:

1. Navigate to Setup.

2. In the Quick Find bar, type in Critical Updates.

3. Select Critical Updates.

4. Locate the Require TLS 1.1 or higher for HTTPS connections under the Update Name column.

5. Click on Deactivate:

Webner Solutions is a Software Development company focused on developing Insurance Agency Management Systems, Learning Management Systems and Salesforce apps. Contact us at dev@webners.com for your Insurance, eLearning and Salesforce applications.

Leave a Reply

Your email address will not be published. Required fields are marked *